Add & Manage Apps

Add Apps

SELECT "Apps" from the Studio left navigation menu

CLICK "Add App"

It's important you select the correct environment when adding your application.

Sandbox: An application that uses sandbox test users to login. The app data can be debugged using the Data Browser tool.

Production: A release-ready app that you want to distribute to one or more users on via the MOTAR Portal. Requires Admin approval of app to show on Portal.

After adding the application it will show up in a list-type format pictured below.

Supported Devices

Supported devices include the list shown below.

You can select the supported devices for your application in MOTAR Studio.

Permission Scopes

Permission Scopes are listed under that section. Your application will start off with Authentication and Profile permission scopes, which are required by MOTAR. To see which permissions you will need for your app, please see https://docs.motar.io/studio/api

Client IDs & Secrets

Here you can generate your Client ID and Client Secret keys for your application. These are used to help the SSO know what app you are attempting to login to, along with a few other things.

Registered Redirect URI

Redirect URIs are set here following this format yourvalue://redirect

Desktop Launch URI

It is optional to set desktop launch URI. This will enable a launch button when a student opens a lesson using your app in the MOTAR dashboard. You can select whether or not you want an auth code to be passed along with the lesson ID in the redirect in the dialog box.

An auth-code can be used to generate an auth token and refresh token. When your app is launched as part of a lesson, you can use the auth code to start a student session without the student logging in again. Use the Generate Auth Token API method to create an auth and refresh token.

Push Notifications

Push Notifications are configured under this section.

Community Listings

Here you can specify Community Listings. With the Community listing being set to the @motar page in this example, the application created would show up on the community page over at:

https://docs.motar.io/motar-apps

Distribution

Here you can select and upload distribution packages for your application. Enter your version number, select the correct platform and app file then Create App Distribution .

Operating System

Upload File Type

Windows

.exe

Android

.apk & Google Play Store (Production)

IOS

.ipa & Apple App Store (Production)

HoloLens

.zip

Oculus Rift

.exe

Below are step-by-step instructions for creating distribution packages, along with info on all platforms MOTAR supports.

Apple App Store

When selecting the Apple App Store Distribution model you will be required to enter the following information: Version: This will be a user-defined version number. App Store ID: This ID will be listed on your public app store listing URL, see screenshot for reference:

URL Scheme: This will be the user-created redirect URL for your production application listing on MOTAR. Find this value under the "Registered Redirect and Launch URIs"

Google Play Store

When selecting the Google Play Store Distribution model you will be required to enter the following information: Version: This will be a user-defined version number. Play Store ID: This ID will be listed on your public play store store listing URL, see screenshot for reference:

Play Store Intent: Setting the Play Store Intent value will launch the play store app and load the targeted page if it's not found on the device. See the example below:

  • market://. Launches the Play Store app to load the target page.

      • market://details?id=dynepic.com.iokids

The following section contains more information on distribution package types.

Android

.apk

1. In Android Studio’s main menu, choose Build → Generate Signed APK.

The Generate Signed APK dialog box appears. This dialog box has a drop-down list in which you select one of your project’s modules.

2. Click Next

As a result, another Generate Signed APK dialog box appears. This box contains a Key Store Path field. In what follows, it’s assumed that you haven’t yet created a key store. (If you’ve created one, you’ll know that you did.)

3. Click the Create New button.

As a result, a New Key Store dialog box opens.

4. Key Store

Choose a name and a location for your key store. Put the full pathname (the location and filename) of the new key store in the dialog box’s Key Store Path field. Enter passwords in the Password and Confirm fields. remember the passwords that you create when you fill in the Password and Confirm fields. You’ll need to enter these passwords when you use this key to sign another app.

In a key store file, each key has an alias

5. Accept the default validity period (25 years).

If you create a key on New Year’s Day in 2016, the key will expire on New Year’s Day in 2041. Happy New Year, everybody! According to the Play Store’s rules, your key must not expire until sometime after October 22, 2033, so 25 years from 2016 is okay.

6. In the Certificate section, fill in at least one of the six fields.

Click OK. As a result, the Generate Signed APK dialog box reappears. This time, many of the box’s fields are filled in for you. Click Next. When you do, one last Generate Signed APK dialog box appears. In this final Generate Signed APK box, take note of the APK Destination Folder. Also, be sure to select Release in the Build Type drop-down list.

7. Click Finish

Your .apk will be stored on your device. If using android studio during this setup the IDE will offer to open the file location of the .apk you just created.

.ipa

Apple

1. Select the destination scheme

In XCode, select Product > Destination and then choose the Generic iOS Device option (in the step ).

2. Archive the project

The previous action will enable the Product > Archive option. Choose them and proceed to export the project as an *.ipa file.

3. Export the binary file from the organizer window

After select Archive option, a dialog will be displayed. Ensure selecting the latest version of your app and click on the "Export..." button on the right side. This action will display another dialog where you must select the distribution mode "Save for Development Deployment" for building the *.ipa file and click "Next".

4. Singing, Restrictions, and Summary

Once you have selected the building mode, XCode will ask you for your Team Development ID. After processing your options, XCode allows you to select which kind of devices can install the app. Once XCode finished building, it will get you a summary of the complete process. Simply click "Next" and the process will finish.

5. Chose the destination and Save

Finally, select the target directory where the *.ipa file will be saved and click on the "Export" button. This action will create a directory on the destination with the *.ipa file of your iOS application.

(.exe)

VR (HoloLens & Oculus)

Hololens & Oculus Distribution

Instructions supporting Hololens & Oculus distribution can be found through the unity export options. After following those instructions take the final exported product, zip it and upload it as a distribution option.

Restricted Access

As a studio user, you can set restricted distribution settings for an application. Search for a user under the restricted access button found on the right of "add distribution".

Enter a search term (minimum of 2 characters) and review available users returned below. From this menu the user can add a student to the access list moving the user from the "Search results:" column to the "Users with access:" column. From here your listing will have restricted access.

The restrict user access modal restricts the distribution of the application to only users who have permission to access it.

After adding the users with access list your app listing under the studio app's page will reflect the change by showing the restricted lock image.

Platform Exporting

Unity Export

Project Setup

  1. Go to File.

  2. Go to Build Settings.

  3. Go to the player settings tab in that dialog box.

  4. Configure your game settings (screen splash,game name,company name,etc,etc)

  5. Select your platform (win/mac/linux/xbox/etc etc)

  6. Click on build.

Unreal Export

Project Setup

  1. In: Project > Description Set the project’s details and thumbnail: > The Project thumbnail will appear in the UE4 Editor browser. > Thumbnail image must be a 192 x 192 resolution PNG

  2. In: Project > Maps & Modes Set default level (Map) for the project:

  3. In: Project > Packaging Choose build configuration > For final distribution choose ‘Shipping‘:

  4. In: Project > Supported Platforms: Make sure Windows is selected:

Exporting the package

  1. Creating the game package: Choose: File > Package Project > Windows > Windows (64-bit) And select an output folder.

  2. A folder named “WindowsNoEditor” will be created, And inside it will be the game executable along with code and assets folders. This package can be renamed and copied to other locations.

.zip